Recent Posts

Pages: [1] 2 3 ... 10
1
Twin Cam / Re: Oil psi
« Last post by Clayton24 on Yesterday at 10:51:19 PM »
Ok i appreciate the advice .
2
General / Re: Leaking gas tank quick-connect
« Last post by Evo160K on Yesterday at 10:42:32 PM »
Replaced a couple of mine several years ago.  They're not garden variety O-rings,  iirc they're made of Viton for the gasoline.
3
Twin Cam / Re: Oil psi
« Last post by Thermodyne on Yesterday at 10:32:42 PM »
The bike has 10,000 miles it does raise with rpmís ! It hasnít lost any oil pressure since new it is a 2015 wethead . Not havin any issues i just thought alittle more oil pressure may make life easier on the valve train is my only reason for the post ! Thanks

If it's been that way since day one, I wouldn't worry about it.  I might put a service gauge on it just for grins, but I wouldn't loose and sleep over it.
4
Twin Cam / Re: Oil psi
« Last post by mike jesse on Yesterday at 10:22:55 PM »
Save your money for the S&S plate and pump.
5
General / Re: Leaking gas tank quick-connect
« Last post by Maddo Snr on Yesterday at 09:22:20 PM »
Thanks all, good advice Scotty,
Cheers.
6
General / Re: S&S super g enrichiner
« Last post by a_disalvo on Yesterday at 09:13:31 PM »
So I got ambitious today and took the rubber band clamps off, installed new O rings w/ 2 wraps of scotch 88 electrical tape, w/ aviation clamps. Pulled the enrichener up and motor fired right up!!! Thanks for the good advise. Frank
7
Twin Cam / Re: newbie more qustions
« Last post by Rockout Rocker Products on Yesterday at 09:11:57 PM »
With the supposed destroying of rubber seals in auto transmissions by ATF it's interesting that some, like my Mini Cooper had the trans sealed for life, no way to even add any fluid without special tools.

 Sorry, not buying it.
8
General / Re: 2016 Ultra Classic Mileage
« Last post by PoorUB on Yesterday at 08:30:25 PM »
I could post my data, but 9346 miles, 237.6 gallons, so 40.04 MPG average. A low of 32.2 MPG and a high of 50.7 MPG.

(weird! I am using the Fuel Buddy app on my phone and it shows 40 MPG, basic math comes out to 39.3!??)
9
Milwaukee-Eight / Re: 114 dyno tests
« Last post by shovelbill on Yesterday at 08:21:32 PM »
thanks for that......



10
EVO 1340 / Re: Cranking Compression
« Last post by JW113 on Yesterday at 08:21:14 PM »
Can't help ya bud. In my dreams. Where'd ya get the 113? Call them and see if they have any info?

-JW
Pages: [1] 2 3 ... 10