December 08, 2021, 01:55:02 AM

News:

For advertising inquiries or help with registration or other issues, you may contact us by email at help@harleytechtalk.com


Fan

Started by Snowyone, July 24, 2018, 02:37:50 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Snowyone

New to me Buell Ulysses and liking it when up and going.  Short legged so getting to the going part posses a few problems.  Fell over the second day I owned damit.  Anyway I'm in Alaska and the weather has been cool and wet so never heard the fan come on.  I'm on my way to Fairbanks on a nice sunny day and when I get near to Delta I stopped for a pipeline picture shot and when I started it up the yellow engine light comes on.  It's still running so get to Fairbanks and being a Sunday I go to the nearest garage(Fred Meyer parking lot) and do a recon.  Fuse to the engine control group is burnt.  Computer service manual says its a fan problem which I believe because it never came on as did the ones on the factory test ride bikes I've tried did.  From the Utube videos it looks like quite a project just getting to the fan.  Any good advice from someone who has been there?

One4Tone

...from what I know about fans there is ussually a relay...if you find it pull it and clean the points..sometimes they get oxidized...so clean and put dialectic grease. This advice comes from experience wiht fans on Crown Vics...not fans on bikes...but I would not be surprised if the principles are the same...good luck

thunderrat

Snowyone,

Checkout the Bad Weather Bikers website (http://badweatherbikers.com/).  Lot's of Buell expertise and there is a Uly and XB section.   Good luck................ted