Author Topic: aaarrrggghhhh, 2016 Sortster 1200 P0371  (Read 451 times)

0 Members and 1 Guest are viewing this topic.

Offline barhopper72

  • Member
  • Posts: 16
  • Country: gb
aaarrrggghhhh, 2016 Sortster 1200 P0371
« on: July 17, 2020, 03:34:29 AM »
Hi guys, 2016 XL, comes up with P0371 CKP SENSOR TOO MANY PULSES, I have replaced crank sensor and ign coil, the bike will start up, go for a ride, after 3 miles or 30 miles, you never can tell!, it starts cutting out, this gets worse until it dies. after leaving it for 20 minutes, sometimes, it will start and run for a few minutes, then cut out again. always shows the same fault code, even when cleared before every test ride,. the bike has only 1600 miles from new. thanks

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #1 on: July 17, 2020, 11:51:17 PM »
Pure stock bike or what has been added?
Sounds like you may have a fuel problem.
Right when it starts to act up, loosen the gas cap. (possible vapor lock) and see if that helps.
Will check back with you on that.
You'll always be my best friend because you know to much.

Offline barhopper72

  • Member
  • Posts: 16
  • Country: gb
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #2 on: July 18, 2020, 12:35:17 AM »
cannot find a fuel problem anywhere! I will spend some time checking wiring, again, today, it seems as if you hit the kill switch when it shuts down.

Offline b0fh

  • Member
  • Posts: 4
  • Country: br
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #3 on: July 18, 2020, 04:42:56 AM »
if replacing the sensor did not fix, check the wiring - that part of the bike is a rat's nest of wires wich get vibrated by the engine, something might be shorting, etc.

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #4 on: July 18, 2020, 07:11:49 PM »
Did you try the gas cap suggestion?
You'll always be my best friend because you know to much.

Offline barhopper72

  • Member
  • Posts: 16
  • Country: gb
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #5 on: July 20, 2020, 12:57:36 AM »
i have tried all the usual stuff. on a real time data run on the diagnostics, i noticed the bike cuts out when engine temp sensor reaches 300C, its done that three times now, gonna swap temp sensor today and see what happens !

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #6 on: July 20, 2020, 06:21:36 PM »
 :up: Let us know.
You'll always be my best friend because you know to much.

Online 72fl

  • Site Supporter
  • Full Member
  • *****
  • Posts: 803
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #7 on: July 21, 2020, 02:36:45 AM »
Seriously 600 degree's farenheit ? You need to get out of traffic and let the Air do it's Job in my opinion

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #8 on: July 23, 2020, 06:38:04 PM »
Need an update.
You'll always be my best friend because you know to much.

Offline barhopper72

  • Member
  • Posts: 16
  • Country: gb
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #9 on: July 24, 2020, 02:26:01 AM »
still waiting for temp sensor, on backorder at HD, did another test run after checking wiring, again, and it started cutting out after 3 miles! I will update more when I next approach the nemesis!

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #10 on: July 29, 2020, 06:27:31 PM »
You getting the sensor from China?   Geeeeeeeez
You'll always be my best friend because you know to much.

Offline barhopper72

  • Member
  • Posts: 16
  • Country: gb
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #11 on: July 30, 2020, 08:21:14 AM »
fitted temp sensor today, got back from a 50 mile run, cut out at a junction one time, re started after  10 mins, rode like a dream!! no  fault codes showing, so far!

Offline Hossamania

  • Site Supporter
  • Full Member
  • *****
  • Posts: 20477
  • Country: us
  • Mostly confused
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #12 on: July 30, 2020, 08:53:49 AM »
I'm confused. With the new temp sensor it still died and you had to wait ten minutes to restart it? It doesn't sound like the issue has quite been solved yet.
When borrowing money from a friend, decide which you need most.

Offline Panzer

  • Full Member
  • Posts: 12179
  • Country: us
  • Live one day at a time.
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #13 on: August 04, 2020, 05:35:28 PM »
Zzzzzzzzzzzzzzzzzzzz
You'll always be my best friend because you know to much.

Offline Hossamania

  • Site Supporter
  • Full Member
  • *****
  • Posts: 20477
  • Country: us
  • Mostly confused
Re: aaarrrggghhhh, 2016 Sortster 1200 P0371
« Reply #14 on: August 04, 2020, 06:50:51 PM »
fitted temp sensor today, got back from a 50 mile run, cut out at a junction one time, re started after  10 mins, rode like a dream!! no  fault codes showing, so far!
I'm confused. With the new temp sensor it still died and you had to wait ten minutes to restart it? It doesn't sound like the issue has quite been solved yet.

Or do you mean that you pulled off and stopped for a ten minute break, then continued on the ride, and had no problems?
When borrowing money from a friend, decide which you need most.