Author Topic: 2000 FXDX Dyna speedo not working properly  (Read 254 times)

0 Members and 1 Guest are viewing this topic.

Offline Shooter1

  • Full Member
  • Posts: 180
  • Country: 00
2000 FXDX Dyna speedo not working properly
« on: October 14, 2020, 07:05:38 AM »
2000 FXDX, noticed a few weeks ago the needle was not dropping fast enough when slowing down for a stop. It drops properly until about 45 mph then it slows down. When you come to a full stop, it is still at about 20mph and slowly drops to about 5mph, then pauses for about 2 sec, then finally drops to zero. I did some research and learned it was probably the speedo sensor. I removed it and cleaned all the scurvy off of it and re-installed, didn't fix it. Bought a brand new Drag Specialty sensor and installed it and it still does it although --maybe-- it's a little more accurate but still far from correct. Is it possible to get a bad sensor? The DS unit was brand new in the package. Can the speedo itself be bad? Anyone else have this issue?  Thanks.

Offline Rusticwater

  • Site Supporter
  • Full Member
  • *****
  • Posts: 501
  • Country: us
  • Lobsterville
Re: 2000 FXDX Dyna speedo not working properly
« Reply #1 on: October 15, 2020, 09:05:43 AM »
Yes speedometers can fail, Iíve had 2 fail on my 2010 Dyna (both under warranty).

I use the GMA combination speedo/tach (74676-09). After I moved to Denver on one hot, sunny day I parked the bike in direct sunlight while I visited a dealer. After I left I noticed my 2 needles werenít moving as they should be, seemed slow or sticking. Turned out the heat had caused the printed speedometer face to separate from the substrate and raise up slightly...just enough to drag the needles.

Another dealer ordered and installed a replacement unit. Within a day or so of that installation the odometer LCD display failed...so that unit had to be replaced as well. Luckily the third GMA unit is still functioning 10 years later.

(So my bike is on its fourth speedometer!)
« Last Edit: October 15, 2020, 04:28:46 PM by Rusticwater »
I Love Scotch! (604)
@scotchpirate

Offline forgetaboutit

  • Member
  • Posts: 11
  • Country: us
Re: 2000 FXDX Dyna speedo not working properly
« Reply #2 on: October 17, 2020, 05:57:21 PM »
I have a 2000 FXD. I had the same issue and it was also intermittent. I found I had poor contact inside my key switch.

I used some CRC electronic contact cleaner spray and it cleared it right up.

When you think about it, with the key being on the side it has the opportunity to pick up a lot of dirt. Hope this helps.

Offline Shooter1

  • Full Member
  • Posts: 180
  • Country: 00
Re: 2000 FXDX Dyna speedo not working properly
« Reply #3 on: October 23, 2020, 08:24:25 AM »
Hmm,  Key switch???  i'll take a look at that although my problem is not intermittent.  Also I'm sure nothing on the face has delaminated or lifted due to heat etc and would affect the movement of the speedo needle. I'm starting to think it may be internal but I will clean up the key switch contacts.
Thanks for the replies.