Author Topic: Bike starts and then stalls  (Read 914 times)

0 Members and 1 Guest are viewing this topic.

Offline wnogood

  • Full Member
  • Posts: 740
  • Country: us
  • Remove the warning labels-clean up the gene pool
Bike starts and then stalls
« on: June 28, 2021, 07:16:25 AM »
HELP! My 2020 street glide has the SE tuner and auto tuner. It has the 122" kit as well. Since the 122" kit was installed, on the first start of the day, it starts, idles up, idles down, coughs, and dies. Start it again, it's fine. If it sits for 8 hours, it still starts fine. It has to sit overnight for this start/stall to happen. The bike runs great. No weird issues other than the cold start problem. Any ideas?
2020 SGS 122" stonewashed white pearl

Offline Clayton24

  • Full Member
  • Posts: 199
  • Country: us
Re: Bike starts and then stalls
« Reply #1 on: June 29, 2021, 10:09:56 AM »
How many miles are on it a dirty throttle body can cause it or an intake leak also

Offline Hossamania

  • Site Supporter
  • Full Member
  • *****
  • Posts: 23106
  • Country: us
  • Mostly confused
Re: Bike starts and then stalls
« Reply #2 on: June 29, 2021, 03:57:41 PM »
After the 122" kit was put in, was it Dyno tuned?
We learn from history that
we do not learn from history

Offline wnogood

  • Full Member
  • Posts: 740
  • Country: us
  • Remove the warning labels-clean up the gene pool
Re: Bike starts and then stalls
« Reply #3 on: June 30, 2021, 06:51:33 AM »
How many miles are on it a dirty throttle body can cause it or an intake leak also

Kit was installed at 94 miles, has 900 now
2020 SGS 122" stonewashed white pearl

Offline wnogood

  • Full Member
  • Posts: 740
  • Country: us
  • Remove the warning labels-clean up the gene pool
Re: Bike starts and then stalls
« Reply #4 on: June 30, 2021, 06:52:06 AM »
After the 122" kit was put in, was it Dyno tuned?

No, it has the SE auto tuning module
2020 SGS 122" stonewashed white pearl

Offline kd

  • Site Supporter
  • Full Member
  • *****
  • Posts: 10104
  • Country: ca
Re: Bike starts and then stalls
« Reply #5 on: June 30, 2021, 06:58:14 AM »
 :crook:  I think most having experience with auto tuning devices have had less than stellar results.  Did the kit have the aluminum intake?  If not, and your auto tune device targeted the lean conditions demanded by the EPA to be legal, you may have experienced overheating and distortion of the plastic intake manifold.  Have you tried to spray down the seals to see if the engine speed stumbles or changes both cold and hot?
KD

Offline jazdad2007

  • Member
  • Posts: 4
  • Country: us
Re: Bike starts and then stalls
« Reply #6 on: October 10, 2021, 05:11:33 PM »
I have noticed this on 122 kit. I recently Re flashed ecm after updating screaming eagle software. Now idles up a bit more then slows down and no stall! Might suggest the same for you. The ecm calibration said revised! Hope this works.

Offline hrdtail78

  • Full Member
  • Posts: 6190
  • Country: 00
    • http://www.cnsspeedshop.com/
Re: Bike starts and then stalls
« Reply #7 on: October 14, 2021, 12:03:40 PM »
I don't know what you can do with that tuner.  No IAC to run adjustment.  No IAC adjustment at all.  No warm up fuel........
Semper Fi