Author Topic: Still not Charging  (Read 421 times)

0 Members and 1 Guest are viewing this topic.

Offline speed limit

  • Full Member
  • Posts: 1094
Still not Charging
« on: July 19, 2021, 12:26:16 PM »
I have replaced Battery,Stator twice,Rotor, rectifier, even the 50 stater relay on my 98 carb Rk and it still won't charge what else can it be?
If it don`t scare you, It ain`t fast enough.

Offline 1340evo

  • Full Member
  • Posts: 489
  • Country: gb
Re: Still not Charging
« Reply #1 on: July 19, 2021, 01:18:20 PM »
I ran an additional earth wire on mine, from the rectifier dirrect to the battery. I wasn't getting a good earth after my frame re-paint. They rely on crinkle washers to bite through the paint and into the frame and give a good conection.
May be worth a try if you're getting an output from the engine but nothing or little at the battery.

:)

Offline kd

  • Site Supporter
  • Full Member
  • *****
  • Posts: 9870
  • Country: ca
Re: Still not Charging
« Reply #2 on: July 19, 2021, 01:33:02 PM »
Do you have a ground lug on the frame backbone up under the rear of the fuel tank?  You can access it by removing the seat. It is problematic.  I have seen a new battery deemed bad because it was loose or not grounding well preventing a proper charge rate.  It should also have a star washer to ensure it is biting into the frame under the paint. 
KD

Offline Tacocaster

  • Full Member
  • Posts: 141
  • Country: ca
  • Sponge for Tech stuff! Keep 'er cumin' !
Re: Still not Charging
« Reply #3 on: July 20, 2021, 03:30:10 AM »
Hmmm.... a '98 RK..... wasn't HD still depending on a ground to frame at the regulator/rectifier mounting point? (single wire on DC side of Reg).
If yes, my approach would be to run a test wire from a known good ground point to the body of the Rec/Reg and see if the battery charge voltage responds appropriately. If yes, clean-up the Rec/Reg mounting points to ensure good frame contact (star washers would help).
Good luck!

Offline xlfan

  • Full Member
  • Posts: 1382
Re: Still not Charging
« Reply #4 on: July 20, 2021, 06:49:53 AM »
Does it turn out VAC at all @ stator output plug?

Offline fleetmechanic

  • Site Supporter
  • Full Member
  • *****
  • Posts: 1204
  • Country: 00
Re: Still not Charging
« Reply #5 on: July 20, 2021, 01:41:40 PM »
Since you have replaced just about everything I would really look hard at the ground status.

Offline speed limit

  • Full Member
  • Posts: 1094
Re: Still not Charging
« Reply #6 on: July 20, 2021, 06:06:43 PM »
Thanks everyone  I went through everything again today scuffed
 up both ground post and cleaned all connections now I'm getting 13 volts at the battery.
If it don`t scare you, It ain`t fast enough.

Offline Burnout

  • Full Member
  • Posts: 1606
  • Country: us
Re: Still not Charging
« Reply #7 on: July 20, 2021, 07:09:04 PM »
 :gob:  I always replace parts before checking the ground!
They don't call me Ironhead Rick just because I'm "hard headed"

Offline hogget

  • Full Member
  • Posts: 52
  • Country: au
Re: Still not Charging
« Reply #8 on: July 20, 2021, 08:46:21 PM »
 
:gob:  I always replace parts before checking the ground!
me too, if i was good at diagnosing, i would have been a doctor  :wink:

Offline guido4198

  • Full Member
  • Posts: 940
Re: Still not Charging
« Reply #9 on: July 21, 2021, 02:55:44 AM »
:gob:  I always replace parts before checking the ground!
:SM: I usually start replacing parts before verifying that the NEW battery is not faulty, straight from the manufacturer.  :banghead:
Doesn't solve my starting problem...but it does help build up a nice inventory of spares for the day when they really are the problem.  :bike:

Offline motorhogman

  • Site Supporter
  • Full Member
  • *****
  • Posts: 3666
  • Country: us
Re: Still not Charging
« Reply #10 on: July 21, 2021, 07:18:13 AM »
Thanks everyone  I went through everything again today scuffed
 up both ground post and cleaned all connections now I'm getting 13 volts at the battery.

13 V is a bit low..
where's the points and condenser ?
Tom / aka motor

Offline kd

  • Site Supporter
  • Full Member
  • *****
  • Posts: 9870
  • Country: ca
Re: Still not Charging
« Reply #11 on: July 21, 2021, 07:50:20 AM »
 :agree:  It would be interesting to see the results of the full range of factory tests such as the wild charging rate with the regulator out of the system etc.   It may tell a story that can be properly analyzed to target the real problem through the manual troubleshooting procedure.  Some of the recent test runs may have perpetuated damages to good components.
KD

Offline Tacocaster

  • Full Member
  • Posts: 141
  • Country: ca
  • Sponge for Tech stuff! Keep 'er cumin' !
Re: Still not Charging
« Reply #12 on: July 21, 2021, 09:51:25 AM »
...and I'm curious to see what the DC voltage is at the MAX fuse to Battery Neg (ground) post while bike running.

On a trouble we were chasing recently we found the voltage good at this point (steady 14VDC) but across the battery terminals it was low (erratic 13VDC). Found loose connection at Starter Positive Lug to be the culprit in our case.