Author Topic: lost oil pressure found a strange situation!  (Read 766 times)

0 Members and 1 Guest are viewing this topic.

Offline Langwilliams

  • Member
  • Posts: 28
  • Country: us
lost oil pressure found a strange situation!
« on: April 15, 2019, 04:47:22 PM »
I did a cam change in my '14 street glide....started up an the oil light came on an I had some tapping. Figured I screwed up everything but I may not have. I'm pulling it apart now since I think I messed up push rod adjustment an bent a valve. I opened the cam chest to survey the damage an an found the cam retaining ring popped out allowing the front cyl cam to walk enough for the secondary/rear tensioner pad to come out. would the pad coming out of the tensioner lower oil pressure enough to give a low oil light? I've done a twin cam cam swap before without any problems so this is stressing me out.
thanks for any info.

Offline Ohio HD

  • Professional Cat Herder
  • Administrator
  • Full Member
  • *****
  • Posts: 20693
  • Country: us
  • OH CRAP!
Re: lost oil pressure found a strange situation!
« Reply #1 on: April 15, 2019, 04:50:32 PM »
I don't have a yes / no answer to that. But I bet it would cause enough pressure loss to trip the switch. Did you use a new snap ring on the cam? In any case, use a new one now. Use one for that application, 11461 HD number.
For the best deal on bike parts, call Calif Phil
     www.harleypartscheap.com

Offline kd

  • Site Supporter
  • Full Member
  • *****
  • Posts: 6391
  • Country: ca
Re: lost oil pressure found a strange situation!
« Reply #2 on: April 15, 2019, 04:58:21 PM »
I don't have a yes / no answer to that. But I bet it would cause enough pressure loss to trip the switch. Did you use a new snap ring on the cam? In any case, use a new one now. Use one for that application, 11461 HD number.


 :agree:  BTW That snap ring has a sharp side to it and it should be installed properly.  Here's a little reading that may be related to your problem with the ring.

https://harleytechtalk.com/htt/index.php?topic=89493.msg1057093#msg1057093

http://harleytechtalk.com/htt/index.php?topic=53301.0
KD

Offline Langwilliams

  • Member
  • Posts: 28
  • Country: us
Re: lost oil pressure found a strange situation!
« Reply #3 on: April 15, 2019, 05:33:07 PM »
yes I used a new one....one came in the cam bearing install kit. I already have another one but I tried to put the one that came off on to see an it kinda floated until I pushed it in the groove so I probably didn't seat it when I installed it. I was afraid I did something wrong with the oil pump but it seems too simple to mess up. I pulled the oil pump parts for inspection an put them back in the same order an followed the instructions for installing the oil pump. I installed 2 screws an turned over the motor to seat the parts.

Offline kd

  • Site Supporter
  • Full Member
  • *****
  • Posts: 6391
  • Country: ca
Re: lost oil pressure found a strange situation!
« Reply #4 on: April 15, 2019, 05:41:06 PM »
That snap ring appears to be directional.  The sharp edge must be installed to the correct side to prevent it from popping out of the groove.  I believe it is described in the threads in my previous post.
KD

Offline tbird

  • Full Member
  • Posts: 753
Re: lost oil pressure found a strange situation!
« Reply #5 on: April 15, 2019, 06:17:18 PM »
Very difficult to figure out which is the sharp side. It was a pain in the ass the few times I did it. Got lucky I guess, none have come apart.

Offline IronButt70

  • Site Supporter
  • Full Member
  • *****
  • Posts: 785
  • Country: us
Re: lost oil pressure found a strange situation!
« Reply #6 on: April 16, 2019, 04:04:22 AM »
Crap. I just buttoned up my first HD cam swap and Iím pretty sure I got it right but for piece of mind Iím going to pull the cover and check it. I did push on it after releasing the pliers and it snapped down into place.  :idunno:
« Last Edit: April 16, 2019, 09:14:31 AM by IronButt70 »
Rollin down lifes hiway never looking back cuz something might be gaining on me

Offline Langwilliams

  • Member
  • Posts: 28
  • Country: us
Re: lost oil pressure found a strange situation!
« Reply #7 on: April 16, 2019, 03:24:08 PM »
so the cam tension pad coming out could trip an oil pressure light?

Offline clap

  • Full Member
  • Posts: 150
Re: lost oil pressure found a strange situation!
« Reply #8 on: April 16, 2019, 09:25:25 PM »
sharp edge of snap ring faces out.Hold it up to the light it can be seen

Offline rbabos

  • Full Member
  • Posts: 13592
  • Country: ca
Re: lost oil pressure found a strange situation!
« Reply #9 on: April 17, 2019, 06:15:37 AM »
sharp edge of snap ring faces out.Hold it up to the light it can be seen
True in direction. What bothers me is the fact the clip is actually being used as a thrust surface against the washer (spacer). No way the washer is going to move due to it's larger surface contact patch, so the clip will rotate against the spacer instead. Cam surface used for thrust should be against the cam plate for that task and the clip basically should have a slight clearance.
Ron

Offline IronButt70

  • Site Supporter
  • Full Member
  • *****
  • Posts: 785
  • Country: us
Re: lost oil pressure found a strange situation!
« Reply #10 on: April 17, 2019, 07:54:44 AM »
Crap. I just buttoned up my first HD cam swap and Iím pretty sure I got it right but for piece of mind Iím going to pull the cover and check it. I did push on it after releasing the pliers and it snapped down into place.  :idunno:
Give me an attaboy. I had it right the first time.  :chop:
Rollin down lifes hiway never looking back cuz something might be gaining on me

Offline Chippitt68

  • Site Supporter
  • Full Member
  • *****
  • Posts: 664
  • Country: us
  • Last tme, I swear.
Re: lost oil pressure found a strange situation!
« Reply #11 on: April 17, 2019, 02:53:53 PM »
Attaboy👍

Offline IronButt70

  • Site Supporter
  • Full Member
  • *****
  • Posts: 785
  • Country: us
Rollin down lifes hiway never looking back cuz something might be gaining on me